请选择 进入手机版 | 继续访问电脑版

通达用户社区[OA论坛]

 找回密码
 立即注册
搜索
查看: 598|回复: 5

关于V11版OA精灵不再支持IE内核

[复制链接]
发表于 2019-9-12 10:04:24 | 显示全部楼层 |阅读模式
试用了一下V11,发现V11版OA精灵不再支持IE内核,如果升级的话会导致一个比较麻烦的问题,我原来在2017版上菜单上加了很多B/S版的应用(大部分都基于IE内核),用OA精灵直接打开就能用了,现版的OA精灵不支持IE内核打开后发现不能兼容应用,不知到有什么办法解决这个问题
回复

使用道具 举报

发表于 2019-9-12 13:49:05 | 显示全部楼层
您好,V11版本兼容适配的是IE9及以上版本浏览器,如果是基于IE9及以上版本,可以正常使用。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2019-9-12 14:14:50 | 显示全部楼层
通达丁森林 发表于 2019-9-12 13:49
您好,V11版本兼容适配的是IE9及以上版本浏览器,如果是基于IE9及以上版本,可以正常使用。 ...

一般B/S软件都有控件,测试了一下,单位里所有的基于IE开发的B/S系统都不能用(如用友A++系统),2017年版的OA精灵是可以用的,有什么办法让菜单调用IE浏览器打开相应的应用,这样就可以解决兼容性问题?

点评

您好,1、如果是精灵打开,可以在MYOA\webroot\inc下oa_config.php 调整默认使用的浏览器 //-- 使用OA精灵时打开OA菜单是否使用操作系统默认浏览器,0 OA精灵浏览器,1 操作系统默认浏览器 $MYOA_USE_OS_BROWSER = 0  详情 回复 发表于 2019-9-12 16:17
回复 支持 反对

使用道具 举报

发表于 2019-9-12 16:17:38 | 显示全部楼层
zwf 发表于 2019-9-12 14:14
一般B/S软件都有控件,测试了一下,单位里所有的基于IE开发的B/S系统都不能用(如用友A++系统),2017年版 ...

您好,1、如果是精灵打开,可以在MYOA\webroot\inc下oa_config.php 调整默认使用的浏览器
//-- 使用OA精灵时打开OA菜单是否使用操作系统默认浏览器,0 OA精灵浏览器,1 操作系统默认浏览器
$MYOA_USE_OS_BROWSER = 0;/
2、如果是非精灵打开,正常使用您想要用的浏览器即可,V11版本使用IE9及以上版本。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2019-9-12 16:46:01 | 显示全部楼层
通达丁森林 发表于 2019-9-12 16:17
您好,1、如果是精灵打开,可以在MYOA\webroot\inc下oa_config.php 调整默认使用的浏览器
//-- 使用OA精 ...

//-- 使用OA精灵时打开OA菜单是否使用操作系统默认浏览器,0 OA精灵浏览器,1 操作系统默认浏览器
$MYOA_USE_OS_BROWSER = 1;/
改为1了,重启精灵,还是没效果,打开菜单窗口还是OA精灵浏览器,这是什么原因?

点评

您好,重启服务器上web服务,修改过的配置文件生效。  详情 回复 发表于 2019-9-16 14:58
回复 支持 反对

使用道具 举报

发表于 2019-9-16 14:58:14 | 显示全部楼层
zwf 发表于 2019-9-12 16:46
//-- 使用OA精灵时打开OA菜单是否使用操作系统默认浏览器,0 OA精灵浏览器,1 操作系统默认浏览器
$MYOA_ ...

您好,重启服务器上web服务,修改过的配置文件生效。
回复 支持 反对

使用道具 举报

小黑屋|手机版|Archiver|通达用户社区[OA论坛] ( 京ICP备14032129号

GMT+8, 2019-10-22 20:00 , Processed in 0.118667 second(s), 18 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表